Categorie
Generale

Configurare OS X 10.10 Yosemite per la rete wifi del Politecnico di Milano

Come l’anno scorso con Mavericks, anche quest’anno il Politecnico di Milano si fa cogliere impreparato al rilascio della nuova versione di OS X.PolimiWiFi

Anche quest’anno ho realizzato uno script che risolve il tutto. Ecco come usarlo.

  1. Scaricate l’installer del Politecnico da www.wifi.polimi.it o connettendovi alla rete aperta polimi
  2. Scaricate il mio script, estraetelo e ponetelo nella stessa cartella dove avete messo l’installer del Politecnico
  3. Eseguite lo script

Potrebbe darsi che vi verrà chiesto di accettare alcuni certificati alla prima connessione, ma poi dovrebbe andare senza problemi.

16 risposte su “Configurare OS X 10.10 Yosemite per la rete wifi del Politecnico di Milano”

Nemmeno col tuo script riesco ad installare i profili necessari per utilizzare la rete “protected”
Ho scaricato il tuo script e l’ho estratto, ho scaricato lo script per OS X 10.6+ dal sito del PoliMi e l’ho estratto, dopodiché li ho entrambi messi in una cartella “A” sul desktop, tuttavia eseguendo il tuo script su terminale mi chiede di metterlo nella stessa cartella di quello del PoliMi (dove è già) e non funziona.
Grazie

Ciao giovanni, prova a non estrarre l’installer del Poli, metti direttamente il .tar che scarichi nella stessa cartella del mio script.
In teoria dovrebbe andare sia che tu l’abbia estratto sia che tu non l’abbia fatto, ma tentar non nuoce 😉

Anche a me il tuo script dice che devo metterli nella stessa cartella pure essendoci già, ho provato anche a non estrarre l’installer del poli come da te suggerito ma la risposta non cambia.
Qualche altro suggerimento?

Grazie,
Ale

NEWS

lasciando tutto nella cartella di download la cosa FUNZIONA.

purtroppo il terminale manda comunque questo messaggio:

Last login: Thu Nov 6 15:34:51 on ttys000
MacBook-Pro-di-Alessio:~ Alessio$ /Users/Alessio/Downloads/fixwifi ; exit;
Estratto l’installer
x installer
x wifiCert.p12
x AirPort.networkConnect
x polimiWiFiSetup
x polimiWiFiSetupLion
x polimiWiFiSetupMLion
x WiFi-polimi-protected.mobileconfig
x WiFi-polimi-eduroam.mobileconfig
Adesso ti verrà richiesta la tua password
Password:
Removed polimi-protected from the preferred networks list
Security type is set to: WPA2 Enterprise
Added polimi-protected to preferred networks list
Security type is set to: WPA2 Enterprise
Added eduroam to preferred networks list
profiles unable to read in dictionary at file ‘WiFi-polimi-protected.mobileconfig’, or via stdin
profiles install for file:’WiFi-polimi-protected.mobileconfig’ and user:’root’ returned -4599 (The operation couldn’t be completed. (OSStatus error -4599.))
profiles unable to read in dictionary at file ‘WiFi-polimi-eduroam.mobileconfig’, or via stdin
profiles install for file:’WiFi-polimi-eduroam.mobileconfig’ and user:’root’ returned -4599 (The operation couldn’t be completed. (OSStatus error -4599.))
logout

[Processo completato]

Che strano che lì vada e altrove no, io i miei test li avevo fatti sul desktop e su una sottocartella del desktop e andava :/

Comunque bene così che alla fine sia andato, quegli errori sono normali, colpa dello stupendo script del Poli. La parte che non va è proprio quella per l’installazione del certificato vero e proprio, ed è per quello che bisogna mettere manualmente la password per installare il certificato.

Guarda, ieri alla fine sono riuscito a connettermi con polimi classico, ma oggi manco quello, non si carica neanche la classica pagina del log in polimi.

Per quanto riguarda la connessione a polimi-protected non sono mai riuscito

Dopo aver inserito user e pass cari al connessione per un po di tempo e infine dice autenticazione a polimi-protected non riuscita, contattare….

Che diasagio lavorare in uni.

Ciao

Ecco la soluzione grazie all’efficiente servizio del di assistenza del poli!

Per la rete polimi veriichi di non aver impostato nessun indirizzo nel tab DNS della finestra che le si apre cliccando su Avanzate nella finesra Network.
Per la rete polimi-protected/eduroam, invece, i nostri tecnici non hanno ancora aggiornato l’installer automatico ma può essere configurata manualmente.
Scarichi il certificato per Android e lo installi(servirà la password di estrazione che trova nelle istruzioni per Android), poi configuri manualmente la rete polimi-protected con i seguenti parametri:
Nome network: polimi-protected
Sicurezza: WPA2-Enterprise
Modalità: EAP-TLS
Identità: Il certificato appena installato – [email protected]
Nome utente: [email protected]

Un saluto, spero possa essere utile

Qualcuno è riuscito a fare andare la rete con il cavo ethernet? Con il wifi ho seguito la soluzione di alessio, ma non so cosa configurare per l’ethernet..

A me è andata insieme al wifi, casomai prova a cliccare manualmente su connetti in preferenze di sistema/network/ethernet, nella sezione 802.11X.

Adesso sono su Mavericks, ma la schermata dovrebbe essere uguale anche su Yosemite: in network/ethernet/avanzate vedi qualcosa del genere?

Bovisa, tra l’altro ho guardato ora la tua immagine e mi sono reso conto che siamo in corso insieme ahah! Quindi dai ti chiederò domani mattina magari.
Grazie mille 😉

Vorrei confermare che la strada suggerita da Alessio poco sopra funziona, ad oggi.

Nome network: polimi-protected
Sicurezza: WPA2-Enterprise
Modalità: EAP-TLS
Identità: Il certificato appena installato – [email protected]
Nome utente: [email protected]

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *