Mini repository: si parte

Dopo il commento di [email protected] mi è ventua una gran voglia di provare a creare un piccolo repository APT per aMSN SVN. Al momento, non ho Ubuntu installato, quindi ho creato il pacchetto .deb con Debian, ma non penso che ci siano problemi, tranne (forse) di dipendenze. Per questo motivo, se qualcuno che usa Ubuntu (o derivati) volesse farmi da tester avrebbe tutta la mia gratitudine.

Repository per aMSN SVN

La riga da aggiungere al vostro /etc/apt/sources.list è la seguente:

deb http://lublog.tuttoeniente.net/repo/ binary/

Non dimenticate di lanciare apt-get update (o sudo apt-get update con Ubuntu) dopo aver modificato sources.list!

18 pensieri su “Mini repository: si parte

  1. su ubuntu amsn da problemi

    Alcuni pacchetti non possono essere installati. Questo può voler
    dire che è stata richiesta una situazione impossibile oppure, se
    si sta usando la distribuzione “unstable”, che alcuni pacchetti
    richiesti non sono ancora stati creati o rimossi da incoming.

    Poiché è stata richiesta solo una singola operazione è molto facile che
    il pacchetto semplicemente non sia installabile, si consiglia
    di inviare un “bug report” per tale pacchetto.
    Le seguenti informazioni possono aiutare a risolvere la situazione:

    I seguenti pacchetti hanno dipendenze non soddisfatte:
    amsn: Dipende: libc6 (>= 2.5-5) ma 2.5-0ubuntu14 sta per essere installato
    Dipende: libgcc1 (>= 1:4.2-20070516) ma 1:4.1.2-0ubuntu4 sta per essere installato
    Dipende: libstdc++6 (>= 4.2-20070516) ma 4.1.2-0ubuntu4 sta per essere installato
    E: Pacchetto non integro

  2. Ci avrei scommesso, era troppo bello che funzionasse tutto al primo colpo 😛
    Una domanda: hai i repository universe e multiverse abilitati?

  3. devo praticamente cambiare a questi

    # Ubuntu supported packages (GPG key: 437D05B5)
    deb http://archive.ubuntu.com/ubuntu feisty main restricted
    deb http://archive.ubuntu.com/ubuntu feisty-updates main restricted
    deb http://archive.ubuntu.com/ubuntu feisty-security main restricted
    deb http://archive.ubuntu.com/ubuntu feisty-proposed main restricted
    deb-src http://archive.ubuntu.com/ubuntu feisty main restricted
    deb-src http://archive.ubuntu.com/ubuntu feisty-updates main restricted
    deb-src http://archive.ubuntu.com/ubuntu feisty-security main restricted
    deb-src http://archive.ubuntu.com/ubuntu feisty-proposed main restricted

    # Ubuntu community supported packages (GPG key: 437D05B5)
    deb http://archive.ubuntu.com/ubuntu feisty universe multiverse
    deb http://archive.ubuntu.com/ubuntu feisty-updates universe multiverse
    deb http://archive.ubuntu.com/ubuntu feisty-security universe multiverse
    deb http://archive.ubuntu.com/ubuntu feisty-proposed universe multiverse
    deb-src http://archive.ubuntu.com/ubuntu feisty universe multiverse
    deb-src http://archive.ubuntu.com/ubuntu feisty-updates universe multiverse
    deb-src http://archive.ubuntu.com/ubuntu feisty-security universe multiverse
    deb-src http://archive.ubuntu.com/ubuntu feisty-proposed universe multiverse

    la parole feisty con gusty?

  4. In teoria no, Gutsy sarà la prossima release di Ubuntu, quindi dovresti solo avere pacchetti più aggiornati, un po’ come passare da Debian Stable a Testing.

  5. Si, penso sia l’unica per farlo funzionare, a meno che tu non ti prenda la briga di scaricarti i sorgenti delle dipendenze mancanti e compili tutto a mano… Se non hai fretta magari provo a prendere dal repo di Gutsy i pacchetti che mancano a feisty e li metto sul mio, dovrei farcela per questa sera.

  6. Niente da fare, ho provato ad aggiungere al mio repo le dipendenze mancanti, ma quelle che ho corretto ne portavano altre, che a loro volta ne portavano altre… meglio lasciar perdere. 🙁 L’unica è usare i repo di Gutsy, 😉

    N.B.: la parola da mettere è “gutsy” e non “gusty” come ho erroneamente scritto prima

  7. ho fatto tutto…. ho installato il tuo amsn ma quando lo avvio da

    amsn
    Segmentation fault (core dumped)

    ora mi chiede un aggiornamento di 1,5 GB… mi sa che aspetterò

  8. Ahia… 🙁
    Comunque spesso i segmentation fault (a me almeno) si risolvono con un riavvio. Comunque la cosa non mi stupisce più di tanto, dato che il pacchetto è compilato con Debian, magari è per quello.

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *